封面

帮助 > 封面
封面

SU-03T离线语音模组

技术开发手册

深圳市机芯智能有限公司

www.aimachip.com

www.smartpi.cn

© 2021 机芯智能有限公司. 版权所有.


修订记录

帮助 > 修订记录
修订记录

修订记录

版本号 | 修订内容 | 时间
V1.1 | 初稿完成 | 2021年11月30
V1.2 | 支持指定自学习命令词、支持定时器、支持防误识别词、支持单命令词优化 | 2021年12月18


SU-03T模组规格书

帮助 > SU-03T模组规格书
SU-03T模组规格书

1、产品概述

SU-03T 是一款低成本、低功耗、小体积的离线语音识别模组，能快速应用于智能家居，各类智能小家电，86 盒，玩具，灯具等需要语音操控的产品。

功能框图：

1.1 外观尺寸

1.2 特性

n 32bit RISC 内核，运行频率 240M

n 支持 DSP 指令集以及 FPU 浮点运算单元

n FFT 加速器：最大支持 1024 点复数 FFT/IFFT 运算，或者是 2048 点的实数FFT/IFFT 运算

n 内置高速SRAM，内置 2MB FLASH

n 内置 3W、单声道 AB 类功放

n 支持 1 路驻极体麦

n 支持I2S input/output

n 支持 5V 电源输入

n 内置 5V 转 3.3V，3.3V 外部负载不超过 150mA

n RC 12MHz 时钟源和PLL 锁相环时钟源

n 内置POR（Power on Reset），低电压检测和看门狗

n 所有GPIO 均可配置为外部中断输入和唤醒源

n 1 个标准SPI Master 接口，最高速率 30MHz

n 1 个SPI Slave 接口最高速率 30MHz

n 1 个全双工UART 最高速率 3Mbps。

n 1 个I2C 主/从控制器最高速率 400kHz

n 2 个PWM 输出

n 1 个 12-bit SAR-ADC 最大 450Khz 采样率

1.3 主要参数

表 1.1 主要参数说明

模块型号 | SU-03T
封装 | SMD18/DIP18
尺寸 | 21*15*3(±0.2)mm
支持接口 | UART/GPIO/ADC/PWM/SPI /I2S/I2C
IO 口 | 8
支持喇叭规格 | VCC=5V，4Ω 负载下，提供高达 2.9W 的输出功率 ； VCC=5V，8Ω 负载下，提供高达 1.8W 的输出功率。

IO 口 | 8
功耗 | 平均工作电流： 60mA
供电范围 | 供电电压 3.6V ~ 5.5V，一般 5V 供电，供电电流 >200mA
工作温度 | -20 ℃ ~ 85℃

2、管脚定义

SU-03T 模组共接出 18 个接口，如图 2.1，表 2.2 是接口定义。

图 2.1.SU-03T 管脚示意图

注意：UART0 串口B0,B1 引脚是调试器的烧录口，串口烧录使用UART1

（B6，B7 脚），具体烧录方式查看烧录文档。

表 2.2 管脚功能定义

序号 | Pin 脚 名称 | 功能说明
1 | VCC | 5V 供电
2 | GND | 数字地
3 | 3V3 | 芯片内部 LDO 输出 3.3V，外部负载不能超过 150mA
4 | B8 | 打印信息引脚，不用可悬空
5 | B7 | ADC13/UART1_TXD/I2C_SCL
6 | B6 | ADC12/UART1_RXD/I2C_SDA
7 | B2 | UART1_TXD/I2C_SCL/TIM3_PWM
8 | MIC- | 驻极体麦负极
9 | MIC+ | 驻极体麦正极
10 | B3 | UART1_RXD/I2C_SDA/TIM4_PWM
11 | A27 | ADC6/SPIS_MOSI/SPIM_MOSI/I2S0_DO/DMIC1_CLK/TIM3_PWM
12 | A26 | ADC5/SPIS_CLK/SPIM_CLK/I2S0_BCLK/I2S1_BCLK/DMIC0_CLK
13 | A25 | ADC4/SPIS_MISO/SPIM_MISO/I2S0_LRCLK/I2S1_LRCLK/DMIC_DAT
14 | B0 | UART0_TXD/I2C_SCL/TIM3_PWM
15 | B1 | UART0_RXD/I2C_SDA/TIM4_PWM
16 | GND | 数字地

17 | SPK- | 喇叭负极
18 | SPK+ | 喇叭正极

3. 电气参数

3.1 电气特性

参数 | 条件 | 最小值 | 典型值 | 最大值 | 单位
存储温度 | - | -65 | 正常温度 | 150 | ℃
工作温度 | - | -20 | 正常温度 | 85 | ℃
最大焊接温度 | IPC/JEDEC J-STD-020 | - | - | 260 | ℃
供电电压 | VCC | 3.6 | 4.2/5 | 5.5 | V

4. 回流焊曲线图

5. 应用电路

6. 联系我们

地址：广东省深圳市宝安区西乡索佳科技园商务大厦 5 楼 A505联系电话：0755-23220940网址：www.aimachip.com


智能公元平台介绍

帮助 > 智能公元平台介绍
智能公元平台介绍

SU-03T离线语音模组具备强大的软件开发定制能力，用户可以使用“智能公元”平台，配置模组的PIN脚、语音识别、输入和输出控制等各项能力，生成语音SDK，并在平台上直接编译、生成固件，实现零代码开发，降低开发难度，提高开发效率，减少开发成本，缩短开发周期。

智能公元平台是机芯智能公司为嵌入式开发打造的开放式开发平台，网址如下：

http://www.smartpi.cn

推荐使用“Chrome”浏览器和“Firefox”浏览器来操作智能公元平台。


快速上手

帮助 > 快速上手
快速上手

一、打开智能公元平台（http://www.smartpi.cn），注册用户（如果已经注册过用户，直接登录平台）

输入用户昵称，正确的自己的手机号码，点击“发送验证码”，手机上会收到短信验证码。

输入短信验证码，再输入自己的登录密码和确认密码，密码和确认密码必须一样，勾选“我已阅读并接受用户协议和隐私政策”，点击“同意并注册”按钮，完成用户注册。

二、用注册的手机号和密码登录平台

三、创建产品

选择产品类别为“台灯”，选择场景为“纯离线方案”，选择模组为“SU-03T”，输入产品名称，选择语言为“中文”，点击“保存”按钮，完成产品的创建。

四、创建产品后，会直接进入产品配置，可以直接用默认配置，不用修改，拉到页面最下面，直接生成新版本

五、在版本列表中，选择新生成的版本，点击“生成SDK”按钮，生成语音SDK

生成SDK涉及到语音模型的生成，比较花时间，具体等待时间和配置的复杂性和服务器的当前负荷相关，请耐心等待。（正常生成SDK后，会发送短信通知到平台账号的手机号中）

（注意：语音SDK可以下载，里面包含了语音代码框架和烧录工具软件，但SDK中的功能是不完整的，完整功能需要在智能公元平台上编译固件，下载平台生成的固件才能获得。）

六、编译生成固件

点击“编译固件”, 点击“添加”按钮，添加固件版本：

选择“产品”，选择“版本”，确定后添加固件版本：

在添加的固件版本上，点击“生成固件”按钮，生成固件：

生成固件大约需要几十秒钟，请耐心等待，固件生成后，可以下载固件，然后烧录到SU-03T模组中使用：


使用烧录器烧录固件

帮助 > 固件烧录 > 使用烧录器烧录固件
使用烧录器烧录固件

简介

本烧录工具操作简易，无需代码编译及调试工作时可使用。

支持 32bit/64bit windows xp，windows7，windows10，通过 SW（SDP）口进行下载。

一、烧录前介绍

开始烧录之前，需要准备：

1、Micro USB 连接线，用于供电

2、烧录器，用于烧录

3、SU-03T

4、固件包

图 1 烧录器

开始烧录之前，需要在智能公元平台，下载语音SDK，语音SDK包中包含烧录器工具软件：

打开语音SDK包，uni_hb_m_solution\image_demo\Hummingbird-M-Production-Tool 内，可看到以下目录结构：

图 3 文件目录结构

和用户相关的目录有以下几个：

n \bin ： 用户存放 bin/mva 文件的目录

n \flash_downloader : flash downloader 存放目录，需要提取相应芯片 SDK 中提供的

downloader.exe

n \ice\libusb-AICE-driver ： 仿真器驱动

根目录有以下用户相关的文件：

图 4 根目录文件

n UniOneDownloadTool_x64.exe ：烧录工具启动 exe

n run_download.bat ： 批量执行脚本例程

二、安装驱动（如已安装，可跳过）

插入烧录器，如在设备管理器看到未知设备，则需要安装驱动。

图 5 未安装驱动时设备管理器显示

1、 准备固件：在智能公元平台上，编译固件，并下载固件包

烧录器烧录的固件文件为：jx_su_03t_release.bin，不要搞错

2、 打开Hummingbird-M-Production-Tool\ice\libusb-AICE-driver，双击 Install_driver.exe，点击同意安装

图 6 驱动文件路径

3、 处于设备管理器页面，右击 AICE（未知设备），更新驱动程序

图 7 属性界面

4、 选择浏览计算机查找驱动

驱动路径： Hummingbird-M-Production-Tool\ice\libusb-AICE-driver

图 8 更新驱动程序界面

图 9 选择驱动文件

5、 点击确定后，回到更新驱动程序页面，点击下一步，等待驱动安装成功。

图 10 更新驱动程序页面

三、进入烧录模式

图 11 SU-03T引脚布局

1.接入烧录器

烧录器连接的SU-03T接口是GND、B1/RXD、B0/TXD

三个接口分别对应烧录器上 GND（3 号脚）、TMS（4 号脚）、TCK(6 号脚)

2.开发板供电，开始烧录

使用 USB 连接线给开发板上电，即接入电源。可直接接电脑，或者任意 5V 电源适配器（如手机充电器）。

点击烧录工具界面“BIN File”按钮，选择待烧录bin 文件：

图 14 烧录工具界面显示

将从平台编译下载的固件包解压缩，选择烧录器烧录的固件文件为：jx_su_03t_release.bin

选择烧录 bin 文件后，点击烧录工具界面“DOWNLOAD”按钮，开始烧录：

图 16 烧录工具界面显示

烧录成功则烧录工具界面打印烧录进度，直到打印“Verify success”信息：

图 17 烧录成功界面显示

如未显示则表示未识别到COM 口，请检查①串口线是否接好，②串口线是否反接 ③ 是否安装UART 对应驱动。

而烧录失败界面将输出错误信息，如下图：

图 18 烧录失败界面显示

如烧录失败，请检查：

① 开发板是否供电

② 开发板 SW Debug 接口是否接好

③ SW 线是否按照要求反接，确认后请回到步骤 1 重新短接上电，重新进入烧录模式。

④ 其他错误，请按照烧录界面提示信息排查问题。

3.烧录成功后，进行测试

烧录完成后，可以点击“RESET AND RUN”按钮重启SU-03T，或者断电重启SU-03T，然后说生成的固件中配置好的唤醒词（平台默认是“你好小美”）进行测试。

四、常见问题解决方案

1. 确定所有操作都正确，但一直烧录不成功？

解决方法：板子上电同时（此时烧录器的红灯熄灭），立即点烧录工具 DOWNLOAD。

2. 烧录器一直亮红灯，开发板重新上电烧录器红灯也不熄灭？

解决办法：仔细检查SW 烧录器连接线线序是否正确，一直红灯一般是接线错误。

3. 开发板上电时红灯熄灭后又快速变红，烧录工具界面点击 DOWNLOAD 打印“connect failed”？

解决办法：打开“设备管理器”，插上烧录器，查看新加设备是否为如下名称：

如果没有该设备，新加设备显示感叹号，则按照“二、驱动安装”章节重新安装设备驱动。


使用串口升级工具烧录固件

帮助 > 固件烧录 > 使用串口升级工具烧录固件
使用串口升级工具烧录固件

概述

本文主要介绍如何在SU-03T模组上用 USB 串口升级工具进行固件升级。

准备工具：开始烧录之前，需要在智能公元平台，下载语音SDK，语音SDK包中包含串口升级工具软件：

打开语音SDK包，串口升级工具在uni_hb_m_solution\image_demo\Hummingbird-M-Update-Tool目录下。

准备固件：在智能公元平台上，编译固件，并下载固件包

串口升级烧录的固件文件为：jx_su_03t_release_update.bin，不要搞错

USB 升级注意事项

SU-03T模组的出厂固件一般都支持串口升级烧录，如果你的模组原来是不支持串口升级烧录的，需要用烧录器烧录固件包中的jx_su_03t_release.bin文件，或者烧录目录“uni_hb_m_solution\image_demo\Hummingbird-M-Update-Tool”下的uni_app_release.bin 或 uni_app_debug.bin 固件。

一、 安装驱动（如已安装，可跳过）

蜂鸟 M 开发板 usb 升级工具 UniOneUpdateTool.exe，提供 UART 串口升级。

由于不同的 uart 转接接口对应的驱动不同，如果接入串口后，始终识别不到 COM 口， 则需联系对应的 UART 转接接口商家询问驱动文件（也可安装驱动精灵获取驱动文件）。

图 1 识别到 com 口

图 2 未识别到com 口

二、 接线方式

n B7 引脚 接 串口RXD

n B6 引脚 接 串口 TXD

n GND 接 串口 GND

如图所示：

连接正确后，打开 UniOneUpdateTool.exe 工具应能看到列表中显示串口，如图 1 所示。如未显示则表示未识别到COM 口，请检查：

① 串口线是否接好

② 串口线是否反接

③ 是否安装UART 对应驱动。

三、 开始升级

1.选择需要升级的固件 bin 文件

平台生成的固件包中，串口升级烧录的固件文件为：jx_su_03t_release_update.bin

2.点击烧录按钮，如图所示，提示栏显示等待设备。（注意：此时设备不要上电）

3.SU-03T板上电开机，正常情况下就会自动开始下载了。

4.升级完成，设备将自动重启进入正常开机状态

5.烧录成功后，进行测试

烧录完成后，可以说生成的固件中配置好的唤醒词（平台默认是“你好小美”）进行测试。

四、 常见问题解答

1. 成功升级完成为什么无法正常开机了？

解答：请检查是否选择了错误的升级固件包，注意支持用 UniOneUpdateTool.exe 程序升级的固件命名带有“_update”后缀，如指定了没带该后缀的固件升级将会无法正常开机。此情况可重新通过 usb 升级工具重新下载正确的固件即可恢复。


产品管理

帮助 > 平台管理能力 > 产品管理
产品管理

一、产品的创建、修改和删除

点击“创建产品”按钮创建产品，点击“查看详情”按钮可以修改已有的产品，点击“删除”按钮可以删除产品（注意：平台不保存用户产品的备份，删除后没有办法恢复，请用户慎重删除）

二、导出产品

点击对应产品的“导出”按钮，可以导出产品的完整信息，导出的结果为json文件，可以作为产品备份用，也可以拷贝给别人分享

三、导入产品

对于平台导出的产品文件，可以点击“导入产品”按钮，导入平台


版本管理

帮助 > 平台管理能力 > 版本管理
版本管理

一、创建产品第一个版本

创建新产品后，会直接进入第一个版本的配置，点击“生成新版本”按钮，会保存产品的第一个版本。如果创建产品后，没有完成第一个版本的创建，后续可以在产品列表中，点击产品“查看详情”按钮，进入产品，然后点击“语音SDK”，继续创建产品版本：

二、在基础版本上创建后续版本

进入产品后，在版本列表中，选择基础版本，点击“编辑”按钮：

修改完配置后，点击“生成新版本”按钮，会创建并保存新的版本：

三、删除版本

进入产品后，在版本列表中，选择版本，点击“删除”按钮，可以删除版本（注意：平台没有版本的备份，删除后将无法恢复，请慎重删除版本）：


固件管理

帮助 > 平台管理能力 > 固件管理
固件管理

一、添加固件

进入产品后，点击“编译固件”，再点击“添加”按钮：

先选择产品，然后再选择版本（版本必须已生成SDK,只有已生成SDK的版本可以选择），然后点“确定”按钮，完成固件添加：

二、生成固件

选择固件版本，点击“生成固件”按钮，等待大约几十秒后，完成固件生成：

三、删除固件

选择固件版本，点击“删除”按钮，可以删除固件：


前端信号处理

帮助 > 平台配置能力 > 前端信号处理
前端信号处理

麦克风配置：SU-03T只支持单MIC。

距离识别：选择合适的识别距离，麦克风在收音的过程中会根据选择，对声音做优化处理。

稳态降噪：适用于产品使用会发出固定频率噪音（例：油烟机、风扇等产品发出的噪音）的降噪方式。稳态降噪功能不能和自学习功能同时打开。


PIN配置

帮助 > 平台配置能力 > PIN配置
PIN配置

1、功能配置：

SU-03T最多支持：

1个烧录器烧录口（SW_CLK、SW_D），不用烧录器时可以配置为其他功能

1个串口（UART1_RX、UART1_TX）

2路硬件PWM（PWM3、PWM4），如果PWM不够可以用GPIO模拟

9个GPIO（A25、A26、A27、B0、B1、B2、B3、B6、B7），请勿使用A28

2、GPIO配置：

输出模式：输出为高/低电平或脉冲，默认电平为系统启动后设置的端口状态，低电平为0V，高电平为3.3V。

输入模式：输入为高/低电平，默认电平为低，则系统启动后会拉低端口电平，默认为高，则系统启动后会拉高端口电平；该模式配合GPIO输入触发模式的行为使用，当发生满足触发条件的电平切换时，会触发该行为。GPIO输入触发会自动消除20毫秒内的电平抖动。

ADC输入：主要用途为通过不同的电压输入来模拟多按键，0至3.3V对应取值为0至4096，偏差为允许取值附近的上下范围；该模式配合ADC输入触发模式的行为使用，当实际取值与设定取值的差的绝对值在偏差范围内时，会触发该行为。

脉冲输入：该模式配合脉冲输入模式的行为使用，当检查到脉冲周期与设定取值的差的绝对值在偏差范围内时，如果达到设定的脉冲个数，会触发该行为。

PWM输出：SU-03T只支持2路硬件PWM，当产品设计需要2路以上PWM时，可以用GPIO模拟PWM输出，GPIO模拟PWM输出的周期精度为10毫秒级。

3、PWM配置：

频率配置：配置为大于0的值，并且小于40KHz

关闭电平反向：计算PWM占空比时，使用高电平部分作为占用部分计算

开启电平反向：计算PWM占空比时，使用低电平部分作为占用部分计算

4、串口配置：

使用串口收发消息，发送消息时，可以在控制中自行填写要发送的16进制串；接收消息时，有固定的格式要求：

帧头：当选择固定格式时，默认是AA 55，当选择配置格式时，可以自行配置帧头

帧尾：当选择固定格式时，默认为55 AA，当选择配置格式时，可以自行配置帧尾

在生成的固件包中，串口输入接口代码在uart目录下，如果需要，可以将串口接口代码文件加入相关项目中，简单修改一下串口发送实现函数，就可以在项目中直接调用封装好的函数，向SU-03T模组发送串口信息。

目前串口通信消息的固定格式如下:

0xAA 0x55 msgno param1 param2 ... 0x55 0xAA

0xAA 0x55 为消息头，也可自行配置

0x55 0xAA 为消息尾，也可自行配置

msgno 为消息编号，占1个字节，默认按串口输入触发行为的顺序编号，从1开始编号

param 为消息参数，整数类型占4个字节，小数占8个字节，从低位到高位顺序发送，字符类型占1个字节

5、上电记忆：

上电记忆是指自动保存端口的状态，当系统重启后，将端口自动恢复到重启前的状态。GPIO输出模式、GPIO模拟PWM输出、PWM都支持上电记忆功能。


唤醒词自定义

帮助 > 平台配置能力 > 唤醒词自定义
唤醒词自定义

使用好的唤醒词，会更容易唤醒系统，带来良好的体验；使用差的唤醒词，会导致唤醒困难，甚至无法唤醒系统。唤醒词自定义规则如下：

只支持中文，3-6个字，4个字为最佳；

避免使用敏感词：包含政治，伟人名字、脏话，黄赌毒等；

避免使用口语化的词汇，口语词汇日常使用频率很高，容易导致误唤醒，如“你好啊”；

唤醒词发音应选择易开口，响度大，发音清晰易分辨的词；

避免使用多音字，唤醒词的音节覆盖应尽量多，差异大；

避免使用叠字，避免连续使用零声母的词，如“安”；

如因使用市面上已存在的唤醒词而产生纠纷，由开发者自行承担，请慎重选择。

唤醒词和后面的免唤醒命令词加起来不要超过10个，否则可能影响唤醒效果。

唤醒灵敏度：一般选择“中”

唤醒回复：可以按需要填写，但不要使用阿拉伯数字（比如1），数字可以用中文数字（比如一）来代替


概述

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 概述
概述

本部分为平台配置能力的主要部分，用于定义设备的各种行为、输入输出、对外表现，功能比较多，包括：

基础信息：用于设备行为的增加、修改、删除，设置触发方式、命令词和回复语

控制详情：配置设备行为的具体输入、具体输出和对外表现

变量定义：支持定义内部变量，变量可以保存运行时状态值，也可以用于语音播放和条件控制

自学习：提供用户自学习唤醒词和命令词的能力，可以用于适配口语和方言等问题

语音导航：提供快速生成语音导航、语音帮助的能力

识别灵敏度：一般选择“中”选项

免唤醒的命令词：可以将一些行为的命令词设置为免唤醒的命令词，实现不唤醒设备下直接识别命令的能力（注意：唤醒词和免唤醒命令词加起来不要超过10个，否则可能影响唤醒效果）


基础信息配置

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 基础信息配置
基础信息配置

一、行为的新增、修改、删除

新增行为：点击“+添加一条”按钮

修改行为：可修改表格中行为的名称、触发方式、命令词、回复语

删除行为：点击行为的“删除”按钮

清空行为：点击“清空”按钮

跳转的行为的控制详情：点击行为的“>>”按钮

二、输入行为的名称

行为的名称由英文、下划线“_”和数字组成，必须英文开头，不区分大小写，15个字符内。行为的名称不能为空，不要使用字母和数字以外的字符，不要使用中文，否则可能导致后续生成SDK和生成固件失败。

三、选择行为的触发方式

行为的触发方式包括必选项目和可选项目，必选项目为主触发方式，只能选一种，可选项目目前只有“附加条件”，用于实现行为的有条件触发。

必选一项的主触发方式包括：

命令词：用户通过语音命令来触发行为

串口输入：通过给模块的串口（UART1_RX）发送消息来触发行为，需要在PIN配置中配置串口（参见手册的“PIN配置”部分内容）

GPIO输入：通过GPIO口的电平切换来触发行为，需要在PIN配置中配置GPIO为输入模式（参见手册的“PIN配置”部分内容）

ADC输入：通常用于模拟多按键输入方式，不同的按键对应不同的电压（0V至3.3V），对应不同的ADC取值（0至4096），当检测到GPIO口的ADC取值符合设定值时，会触发该行为。需要在PIN配置中配置GPIO为ADC输入（参见手册的“PIN配置”部分内容）

脉冲输入：通过检测GPIO口的脉冲输入，当输入脉冲的周期和个数符合设定值时，会触发该行为。需要在PIN配置中配置GPIO为脉冲输入（参见手册的“PIN配置”部分内容）

事件触发：支持在系统启动、系统退出唤醒时，触发该行为

触发方式的可选项目目前只有一项“附加条件”，不能单独选择，只能在选择一项必选的主触发方式后，才能选择“附加条件”。附加条件的目的是实现行为的有条件触发，只有满足附加条件，行为才能触发后执行，如果不满足附加条件，即使达到了主触发条件的要求，行为也不会被执行。

四、输入命令词

当选择主触发方式为“命令词”时，才能输入命令词。

命令词是想要定义的语音话术，用户必须按照定义的话术说出才有效。如用户可以使用“设置十五度”“十五度”来实现同一个设置温度15度的控制。

每条命令词限 2 - 10 个字符，仅支持中文。

一个行为的命令词允许填多条，多条命令词之间用“|”隔开。当设置多条命令词时，说每个命令词都能触发该行为。

五、输入回复语

当选择主触发方式为“命令词”时，才能输入回复语。

回复语是针对该条控制指令的设备回复播报。

单条回复语不得超过500个字符，支持中英文、逗号、句号、问号，不要使用阿拉伯数字，可以用中文数字来代替。

回复语中支持标签<py></py>，来指定某些多音字播报时的读音。

例：已调<py>tiao2</py>至中<py>zhong1</py>风档，

注：拼音声调范围为 1 - 5，1 - 4 对应一声到四声，5对应轻声。

播报为：已调(tiao2)至中(zhong1)风档。

一个行为的回复语允许填多条，多条回复语之间用“|”隔开。当设置多条回复语时，行为被触发后，系统会随机选择一条回复语进行播报。

六、批量编辑命令词和回复语

点击“命令词编辑”按钮，可以打开离线命令词编辑器，进行命令词和回复语的批量编辑：

注意输入要满足语法格式的要求。点击“确定”按钮，会同步修改基础信息表格中的内容。


基本操作

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 基本操作
基本操作

控制详情中的第一个行为（行为名wakeup_uni）为唤醒行为，如果需要对唤醒行为进行控制（比如增加条件唤醒、唤醒后执行某些动作），可在这个行为上进行配置。

添加触发：点击“添加触发”按钮，可以安装基础信息中指定的触发方式，进行行为的主触发方式配置和附加条件配置，命令词触发的行为不需要再进行主触发方式配置。一个行为只能添加一个主触发，但可以添加多个附加条件，多个附加条件之间是“或”的关系，只要有一个附加条件得到满足，就可以触发执行。

添加控制：点击“添加控制”按钮，可进行行为触发后执行的动作配置。一个行为可以添加多个控制。

跳转到基础信息：点击“<<”按钮，可以从控制详情中跳转到基础信息。


命令词触发

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加触发 > 命令词触发
命令词触发

命令词触发方式已经在基础信息中设置命令词，不需要再“添加触发”。


串口输入触发

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加触发 > 串口输入触发
串口输入触发

前提条件：

PIN配置中，配置了串口（参见手册“PIN配置”部分内容）

行为基础信息中，选择了“串口输入”为主触发方式

点击“添加触发”按钮，选择触发方式为“串口输入”，选择串口为“UART1_RX”，信息编号默认按串口触发行为的顺序自动分配，如果有需要可以修改，但是不同串口触发行为之间的信息编号不能重复。输入参数中，如果后续控制中没有使用参数的需要，可以不添加参数。测试消息为可触发该行为的消息示例，可以用串口发送工具向模块的串口发送，进行测试：

如果行为的后续控制中，需要使用参数，比如播放“当前温度是XX度”，则可以在串口中添加参数：

串口参数类型支持char、int、double、unsgined char四种类型，添加参数时，测试消息也会同步变化，char类型和unsigned char类型参数占1个字节，int类型参数占4个字节，double类型参数占8个字节，具体编码方式可以参见生成固件包中uart目录下的c代码文件。

点击“确定”按钮后，完成触发的添加，在控制详情表格中会显示触发的摘要信息：


GPIO输入触发

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加触发 > GPIO输入触发
GPIO输入触发

前提条件：

PIN配置中，配置了GPIO为输入模式（参见手册“PIN配置”部分内容）

行为基础信息中，选择了“GPIO输入”为主触发方式

点击“添加触发”按钮，选择触发方式为“GPIO输入”，在GPIO输入中，选择输入的GPIO口及触发电平：

如果选择“低电平”，则行为会在GPIO口从高电平切换到低电平时触发；如果选择“高电平”，则行为会在GPIO口从低电平切换到高电平时触发。如果GPIO口的电平没有发生切换，则不会触发该行为。平台生成的固件中，会过滤掉20毫秒内的电平抖动，也就是说，如果电平切换后在20毫秒内又切换回来，将不会触发该行为。

点击“确定”按钮后，完成触发的添加，在控制详情表格中会显示触发的摘要信息：


ADC输入触发

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加触发 > ADC输入触发
ADC输入触发

前提条件：

PIN配置中，配置了GPIO为ADC输入模式（参见手册“PIN配置”部分内容）

行为基础信息中，选择了“ADC输入”为主触发方式

点击“添加触发”按钮，选择触发方式为“ADC输入”，在输入参数中，选择输入的GPIO口及ADC取值：

ADC触发主要用途为通过不同的电压输入来模拟多按键，0至3.3V对应取值为0至4096，偏差为允许取值附近的上下范围（偏差在PIN配置中设置），当实际取值与设定取值的差的绝对值在偏差范围内时，会触发该行为。为了便于填写ADC触发的取值，平台允许通过播放语音，将ADC取值播放出来，这也可以作为确定ADC取值的调试手段，具体可参见手册“播放语音”部分内容。当存在多个ADC触发行为时，各个行为的ADC取值应尽量分隔开，也就是多按键的电压要尽量分隔开，避免误触发。

点击“确定”按钮后，完成触发的添加，在控制详情表格中会显示触发的摘要信息：


脉冲输入触发

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加触发 > 脉冲输入触发
脉冲输入触发

前提条件：

PIN配置中，配置了GPIO为脉冲输入模式（参见手册“PIN配置”部分内容）

行为基础信息中，选择了“脉冲输入”为主触发方式

点击“添加触发”按钮，选择触发方式为“脉冲输入”，选择输入的GPIO口，填写“周期”和“次数”：

通过检测GPIO口的脉冲输入，当检查到脉冲周期与设定取值的差的绝对值在偏差范围内时（偏差在PIN配置中设置），如果达到设定的脉冲次数，会触发该行为。目前对脉冲周期的检测精度不高，为了通过触发的准确性，建议将输入脉冲的周期设置在100毫秒以上，如果有多个脉冲输入触发的行为，各个行为的输入脉冲周期需要设置为间隔100毫秒以上。

点击“确定”按钮后，完成触发的添加，在控制详情表格中会显示触发的摘要信息：


事件触发

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加触发 > 事件触发
事件触发

前提条件：

行为基础信息中，选择了“事件触发”为主触发方式

事件触发支持系统支持下面的事件类型：

“退出唤醒”事件触发：点击“添加触发”按钮，选择触发方式为“事件触发”，选择事件类型为“退出唤醒”，触发类型可以多选，可选项目如下：

语音触发：通过语音命令系统退出唤醒

自动触发：超时系统自动退出唤醒

接口触发：调用系统设置接口退出唤醒

“系统启动”事件触发：点击“添加触发”按钮，选择触发方式为“事件触发”，选择事件类型为“系统启动”：

点击“确定”按钮后，完成触发的添加，在控制详情表格中会显示触发的摘要信息：

“播音开始”事件触发：点击“添加触发”按钮，选择触发方式为“事件触发”，选择事件类型为“播音开始”：

点击“确定”按钮后，完成触发的添加，在控制详情表格中会显示触发的摘要信息：

“播音结束”事件触发：点击“添加触发”按钮，选择触发方式为“事件触发”，选择事件类型为“播音结束”：

点击“确定”按钮后，完成触发的添加，在控制详情表格中会显示触发的摘要信息：

“定时器超时”事件触发：点击“添加触发”按钮，选择触发方式为“事件触发”，选择事件类型为“定时器超时”，选择“定时器”：

点击“确定”按钮后，完成触发的添加，在控制详情表格中会显示触发的摘要信息：


附加条件触发

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加触发 > 附加条件触发
附加条件触发

前提条件：

行为基础信息中，已选择了主触发方式

行为基础信息中，触发方式中同时选择了“附加条件”

点击“添加触发”按钮，选择触发方式为“附加条件”，选择“条件子项”：

条件子项支持使用GPIO端口的状态和变量的状态，一个附加条件支持添加多个“条件子项”，多个条件子项之间是“与”的关系，需要同时满足条件子项的要求，行为才能触发后执行。一个行为也支持添加多个“附加条件”，多个附加条件之间是“或”的关系，只要有一个附加条件得到满足，行为就会触发执行。

点击“确定”按钮后，完成触发的添加，在控制详情表格中会显示触发的摘要信息：


端口输出控制

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加控制 > 端口输出控制
端口输出控制

一、GPIO输出控制

点击“添加控制”，控制方式选择“端口输出”，控制类型选择一个GPIO口（已在PIN配置中设为GPIO输出模式），动作选择“设置”，参数可选“高电平触发”、“低电平触发”、“反电平触发”：

高电平触发：将GPIO口设置为高电平状态

低电平触发：将GPIO口设置为低电平状态

反电平触发：将GPIO口设置为与原来相反的电平状态，原来是高电平，则会设为低电平，反之亦然

如果在“动作”中设置为“脉冲”，输入“周期”和“次数”，则可以在GPIO口上输出脉冲：

脉冲输出默认是输出次数完成后，自动停止，目前没有接口可停止脉冲输出，如果设置了很长时间的脉冲输出，需要停止的话，可以再次设置一个很短的脉冲输出，这会中断掉原来的长脉冲，间接实现停止长脉冲的目的。

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：

二、PWM输出控制

点击“添加控制”，控制方式选择“端口输出”，控制类型选择一个PWM口（已在PIN配置中设为PWM输出模式），动作选择“设置”，输入“占空比”：

这样将会把PWM口设置成相应的占空比。“动作”中也可以选择“增加”或“减少”，这样会把PWM口的占空比增加或减少相应的占空比：

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：

三、串口输出控制

点击“添加控制”，控制方式选择“端口输出”，控制类型选择UART1_TX口（已在PIN配置中配置了串口），动作选择“发送”，参数中输入要发送的16进制数串：

参数中填写的串口发送数据要按提示要求的格式来填写，格式不合要求，可能会导致生成固件失败。

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：

四、GPIO模拟PWM输出控制

点击“添加控制”，控制方式选择“端口输出”，控制类型选择一个模拟PWM的GPIO口（已在PIN配置中设为GPIO的PWM输出模式），动作选择“设置”，输入“占空比”：

这样将会把模拟PWM口设置成相应的占空比。“动作”中也可以选择“增加”或“减少”，这样会把模拟PWM口的占空比增加或减少相应的占空比：

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：


播放语音控制

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加控制 > 播放语音控制
播放语音控制

点击“添加控制”，控制方式选择“播放语音”，语音内容可以添加文本、串口参数、变量：

可以播放固定文本的语音，也可以播放数值型的可变语音。如果在一个串口触发的行为中，串口输入带有参数，则播放语音中可以选择串口参数进行播报；如果在变量定义中定义有变量，则播放语音中也可以选择变量进行播报。为了方便ADC触发和脉冲触发方式的调试，也可以在“添加变量”中，选择播放ADC基础值和脉冲检测值：

注意：语音播放有一个特点，就是后面播放的语音会中断正在播放的语音，包括在基础信息中设置的回复语播放，所以，如果一个行为中有多个语音播放控制，则需要在后面播放的语音控制中设置延时播放，否则只会听到一条语音播放。

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：


系统设置控制

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加控制 > 系统设置控制
系统设置控制

一、播放控制

点击“添加控制”，控制方式选择“系统设置”，类别选“播放控制”，选择需要的操作：

播放控制目前支持下面操作：

停止播放：停止当前正在播放的语音

最小音量：设置音量到最小音量，重启后能保持音量大小

最大音量：设置音量到最大音量，重启后能保持音量大小

中等音量：设置音量到中间音量，重启后能保持音量大小

增加音量：将音量调高一档，重启后能保持音量大小，可以设置延时恢复

减少音量：将音量调低一档，重启后能保持音量大小，可以设置延时恢复

设为静音：设置喇叭为静音，可以设置延时恢复

取消静音：取消喇叭静音，可以设置延时恢复

无回复播报：系统进入无回复播报模式，可以设置延时恢复

有回复播报：系统退出无回复播报模式，可以设置延时恢复

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：

二、识别控制

点击“添加控制”，控制方式选择“系统设置”，类别选“识别控制”，选择需要的操作：

识别控制目前支持下面操作：

退出唤醒：系统从唤醒状态退出到非唤醒状态，可以设置延时恢复

进入唤醒：系统从非唤醒状态进入唤醒状态，可以设置延时恢复

允许语音识别：系统可以识别唤醒词和命令词，可以设置延时恢复

关闭语音识别：系统不对唤醒词和命令词进行识别，可以设置延时恢复

允许识别词：允许对某个唤醒词或命令词进行识别，重启后能保持设置，可以设置延时恢复

禁止识别词：禁止对某个唤醒词或命令词进行识别，重启后能保持设置，可以设置延时恢复

禁止超时退出唤醒：超时后不退出唤醒状态，可以设置延时恢复

允许超时退出唤醒：超时后自动退出唤醒状态，可以设置延时恢复

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：

三、重启控制

点击“添加控制”，控制方式选择“系统设置”，类别选“重启控制”，选择需要的操作：

重启控制目前支持下面操作：

重置重启：直接重启

看门狗重启：看门狗超时重启

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：

四、定时器控制

启动定时器：点击“添加控制”，控制方式选择“系统设置”，类别选“定时器控制”，选择“启动定时器”，选择需要的操作：

定时器：在定时器定义中已定义的定时器

超时时长：启动后多长时间定时器会超时

单次触发：定时器只触发超时一次

连续触发：每间隔一次超时时长，定时器就会触发超时一次

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：

停止定时器：点击“添加控制”，控制方式选择“系统设置”，类别选“定时器控制”，选择“停止定时器”，选择需要的操作：

定时器：在定时器定义中已定义的定时器

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：


变量设置控制

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加控制 > 变量设置控制
变量设置控制

点击“添加控制”，控制方式选择“变量设置”，选择“变量”（在“变量定义”中已定义），操作选择“设置”，方式选择“数值”，输入数值，可以将变量设置为对应数值：

如果是在一个带参数的串口触发行为中，方式可以选择“参数”，可以选择将指定串口参数值设置为变量值：

如果方式选择为“变量”，可以选择将其他变量值设置为当前变量值：

变量控制中，操作也支持“增加”和“减少”，选择增加，会给当前变量值增加指定的值，反之亦然。变量设置还支持“延时恢复”，可以设定在一定时间后恢复为原来的值：

点击“确定”按钮后，完成控制的添加，在控制详情表格中会显示控制的摘要信息：


延时执行控制

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加控制 > 延时执行控制
延时执行控制

一、行为中控制的执行顺序

行为中的各种控制可以分为长耗时操作和短耗时操作，其中：

长耗时操作：播放语音、脉冲输出

短耗时操作：端口输出（除脉冲输出）、系统设置、变量设置

对于短耗时操作，执行时是顺序串行执行的，对于长耗时操作，由于其他操作无法等待其完成，所以是并行执行的。

如果需要严格的控制行为中动作的顺序，可以通过设置控制的延时执行来实现。

特别的，语音播放有一个特点，就是后面播放的语音会中断正在播放的语音，包括在基础信息中设置的回复语播放，所以，如果一个行为中有多个语音播放控制，则需要在后面播放的语音控制中设置延时播放，否则只会听到一条语音播放。

二、延时执行控制

在添加控制或编辑控制时，“是否延时输出”设为“是”，再输入“延时时长”（单位为毫秒），可以实现延时执行：

在控制详情中，延时执行动作在操作前会有一个“时钟”图标：

三、延时恢复或延时电平翻转

对于GPIO电平设置，在添加控制或编辑控制时，“延时电平翻转”设为“是”，再输入“延时时长”（单位为毫秒），可以实现延时一段时间后，将电平设置为反电平：

对于PWM输出、变量设置、部分系统设置操作，可以设置延时恢复：

在控制详情中，延时恢复/延时电平翻转的动作会在操作后有一个“时钟”图标：

四、特别说明

针对GPIO和PWM端口，如果延时控制或延时翻转/恢复处于等待中时，如果对该端口的后续操作也带有延时控制或延时翻转/恢复设置，将会取消原来正在等待的操作，执行新的操作。


条件执行控制

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 控制详情配置 > 添加控制 > 条件执行控制
条件执行控制

在添加控制或编辑控制时，“是否条件执行”设为“是”，再选择条件子项，可以实现条件执行：

条件子项支持端口状态作为条件，也支持变量值作为条件。

多个条件子项之间是“与”的关系，多个条件子项只有同时满足，才能执行控制动作。

行为的“附加条件”与控制中的“执行条件”的作用范围不同，附加条件影响的是整个行为，而执行条件影响的只是行为中的一个控制动作，可以实现更精细的控制。执行条件与变量配合，可以实现诸如“语音命令二次确认后再执行”这样的典型控制。

在控制详情中，条件执行的动作会在最前面有一个“路牌”图标：


变量定义

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 变量定义
变量定义

选择“变量定义”页签，可以进入变量定义，点击“+添加变量”可以新增变量定义：

变量名：变量名不能为空，输入的变量名要满足C语音的变量名规则，变量名也不能重复，否则会导致后续固件生成失败

类型：目前支持char、int、double、unsigned char类型

默认值：变量的初值

备注：便于后续记忆和理解，可不填

持久化：启用后，该变量的值会保存起来，系统重启后，会将该变量的值恢复成重启前的值

变量的典型用途是用于保持运行中的内部状态，并可以作为条件来判断一个行为或一个控制动作是否应该执行。


定时器

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 定时器
定时器

选择“定时器”页签，可以进入定时器定义，点击“+添加定时器”可以新增定时器定义：

定时器名称：不能为空，输入的定时器名要满足C语音的变量名规则，定时器名也不能重复，否则会导致后续固件生成失败

备注：便于后续记忆和理解，可不填

定义定时器后，可以在行为的控制中启动定时器和关闭定时器，也可以通过事件触发的行为来监视定时器的超时，执行需要的动作。


自学习

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 自学习
自学习

一、自学习功能配置

自学习功能允许用户学习一个唤醒词和多个命令词，可以处理口音和方言的适配问题，并支持用户使用个性化的唤醒词和命令词。

选择“自学习”页签，并打开“自学习功能”开关：

自学习功能内置了六个学习相关的行为，这些行为是固定的，不能增加或删除，但是可以按自己的要求修改这些行为的命令词和回复语，注意命令词不能和其他行为的命令词重复：

开始学习：触发后开始学习命令词

重置学习：将系统存储的原有的自学习数据删除，包括自学习唤醒词和自学习命令词

开始学习命令词：触发后开始学习命令词，需要学习的命令词可以按需要增加

开始学习唤醒词：触发后开始学习唤醒词

清除学习命令词：将系统存储的原有的自学习命令词数据删除

清除学习唤醒词：将系统存储的原有的自学习唤醒词数据删除

点击“+学习命令词”按钮，可以增加需要学习的命令词：

选择的“行为”是指这条自学习的命令被识别后，对应执行的行为。

“学习命令”是指当需要指定学习这条命令（单条学习）时，需要说出的语音词条。

学习回复语是指开始学习这条命令时，系统播报的提示语，可以按需要修改。

自学习支持两种模式：指定学习单条命令，按顺序学习所有需要学习的命令。

当指定学习单条命令时，需要说出这里配置的这条命令的学习命令，比如上面的“学习命令词打开台灯”。

当按顺序学习时，需要说出“开始学习命令词”（这个词条也可以修改），用于学习命令词要求按顺序一次学完，为了保证学习顺利完成和用户比较好的体验，建议增加的学习命令词数量不要超过十个。在顺序学习过程中，如果想中止学习，可以说“退出学习”。

学习过程中，要求的成功次数和允许的失败次数，也可以在“学习成功次数”和“学习失败次数”中修改。

二、自学习功能的使用

1、学习唤醒词

学习完成后，可以使用学习的唤醒词“芝麻开门”来唤醒设备。

2、单条学习命令词

学习完成后，需要说“客厅灯”来开灯。

3、顺序学习命令词

4、学习命令重置/清除

唤醒设备，

说“重置学习”会重置所有学习数据，包括命令词和唤醒词。

说“清除学习命令词”会清除学习命令词，保留学习唤醒词。

说“清除学习唤醒词”会清除学习唤醒词，保留学习命令词。


语音导航

帮助 > 平台配置能力 > 离线命令词及应答语自定义 > 语音导航
语音导航

语音导航功能可以帮助开发者快速生成语音导航/帮助的命令和语音播报，帮助用户更好的使用产品。

选择“语音导航”页签，并打开“语音导航功能”开关：

语音导航的触发命令词可以按需要修改，但要注意不要和其他行为的命令词重复。

点击“+命令词”按钮，可以增加需要帮助的行为的命令词的播报，“开头内容”、“结尾内容”、命令词的播放内容都可以按需要进行修改。


免唤醒的命令词

帮助 > 平台配置能力 > 免唤醒的命令词
免唤醒的命令词

可以设置免唤醒命令词，无需唤醒，说出命令词即可控制设备，执行免唤醒命令词之后， 设备处于待唤醒状态，免唤醒命令词和唤醒词总条数不超过10条。


防止误识别命令词

帮助 > 平台配置能力 > 防止误识别命令词
防止误识别命令词

对于语音识别而言，识别率永远不可能为 100%，而误识别率永远不可能为 0%。

比如对于词条“你好小美”，如果你说“你好小”，会有75%的相识度，容易被误识别。

对于一些与命令词相近，容易被误识别的词，可以设置到防误识别词中：

注意防止识别词和已有的命令词不能重复。


发音人配置

帮助 > 平台配置能力 > 发音人配置
发音人配置

支持七种风格的声音类型，点击“试听”按钮，可以试听对应类型的声音，可以选择自己喜欢或适合产品风格的发音人：

音量：系统默认的音量

语速：系统播报声音的语速

亮度：系统播报声音的亮度


开机播报及退出

帮助 > 平台配置能力 > 开机播报及退出
开机播报及退出

可以选择是否有“开机播报”，如果设置了开机播报，系统从完全断电后，上电重新启动时，会播报设置好的开机播报语音。如果设置为“有开机播报”，则开机播报的内容不能为空，否则可能导致后续播放回复语异常：

支持配置超时退出的时间和超时退出播报的回复语。

也支持设置主动退出的命令词和主动退出的回复语。


个性化音频

帮助 > 平台配置能力 > 个性化音频
个性化音频

个性化音频为可选配置，当需要播放系统无法生成的特定风格的发音时，或者需要播报一些短音频比如告警声音时，可以使用个性化音频来实现：

点击“+点击添加”按钮，可以为行为的回复语指定替代的音频：

可以选择“词条”，再选择已上传的“音频文件”，可以点击“播放”试听音频文件，如果音频文件还没有上传，可点击“上传”按钮：

点击“+上传音频”按钮，可以上传音频文件。目前只支持上传mp3和wav格式的音频文件，在上传音频时，系统会自动将音频文件转换为适合模块播放的音频格式。

由于SU-03T模块只有2MB的Flash存储，而且不能用语音打断正在进行的音频播放，建议只上传比较小的短音频文件，不要上传大的长音频文件，避免因生成的固件超过2MB而无法烧录或烧录后无法正常工作，或者因长时间播放音频不能退出而无法响应语音指令。


优化配置

帮助 > 平台配置能力 > 优化配置
优化配置

优化配置为可选设置，通过调整系统参数，优化系统的性能：

在优化选项中，阈值越大越敏感，但错误率也会增高，未设置时自动取默认值。如要降低休眠影响，建议将“深度休眠阈值”、“唤醒阈值”、“二次唤醒阈值”都设为相同值，将“进入休眠时间”设为2天或更多。

支持对单个命令词进行阈值调整：


开发英文产品

帮助 > 开发英文产品
开发英文产品

智能公元平台支持对SU-03T模块开发英文产品。在创建产品过程中，在“选择语言”时，选择“英文”：

智能公元平台目前在界面上没有进行英文话，显示的是中文，开发英文产品时，只要将所有的唤醒词、命令词、回复语填写成英文即可：

英文产品目前没有支持“自学习功能”，其他功能和中文产品相同。


常见问题

帮助 > 常见问题
常见问题

一、问题：固件烧录后，发现有些功能缺失？

可能原因：没有在网站平台上编译、生成固件，没有烧录平台上生成的固件，而是下载了语音SDK，烧录了语音SDK中的固件。语音SDK中只包含语音代码框架和烧录工具软件，不包含平台上增强的各种触发、控制功能。

解决办法：在平台上编译生成固件，并下载正确的固件烧录。

二、问题：生成语音SDK失败

可能原因：配置中存在空的唤醒词记录，或者存在空的行为记录，或者存在空的命令词，或者命令词和回复语不满足输入格式要求。

解决办法：检查配置，修改配置后重新生成SDK。

三、问题：在平台上生成固件失败

可能原因：配置中存在空的触发记录，或者存在空的控制记录，或者定义的变量名不合要求，或者使用了空的串口参数或变量，或者串口发送的信息内容未填写等。

解决办法：检查配置，修改配置后重新编译生成固件。

四、问题：成功烧录固件后无响应或死机

可能原因：烧录了错误的固件文件，或者固件文件超过2M或接近2M大小

解决办法：如果使用烧录器烧录，应烧录文件为jx_su_03t_release.bin，如果使用串口升级烧录，应烧录文件为jx_su_03t_release_update.bin。如果是固件文件超过或接近2M大小，则需要减小固件的大小，可以将配置中多个行为的回复语设为相同，比如都设为“已设置”或“已执行”，这样可以减少固件中包含的音频数量，从而减小固件文件的大小。

五、问题：成功烧录固件后唤醒困难

可能原因：长时间放置后进入深度休眠，唤醒比较可能，或者使用了不容易唤醒的唤醒词

解决办法：在优化配置中，按提示调整优化选项，测试唤醒是否有改善。更换一下唤醒词：

避免使用口语化的词汇，口语词汇日常使用频率很高，容易导致误唤醒，如“你好啊”；

唤醒词发音应选择易开口，响度大，发音清晰易分辨的词；

避免使用多音字，唤醒词的音节覆盖应尽量多，差异大；

避免使用叠字，避免连续使用零声母的词，如“安”；

唤醒词和后面的免唤醒命令词加起来不要超过10个，否则可能影响唤醒效果。